WLan-Modul defekt - schwarzer Bildschirm (mögliche Reparaturlösung)

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    ACHTUNG: In Deutschland muß Deine Drohne per Gesetz mit einem Drohnen-Kennzeichen versehen sein! Diese Plakette muß feuerfest sein und Deinen Namen und Anschrift enthalten. Ein passendes Kennzeichen bekommst Du hier.

    • WLan-Modul defekt - schwarzer Bildschirm (mögliche Reparaturlösung)

      Ich habe vor ein paar Tagen einen interessanten Bericht im DJI-Forum gelesen, wonach es in einigen Fällen möglich sein soll, das WLan-Modul, bzw. das nicht mehr funktionierende Video-Board darin durch Flashen wiederzubeleben. Hört sich sehr interessant an. Es gibt dort auch eine genaue Anleitung als .pdf zur Vorgehensweise, allerdings in englisch.

      Ich habe den Verfasser des Pdf-Files mal angeschrieben und ihn gefragt, ob ich seinen Text übersetzen und verteilen darf und habe die Erlaubnis von ihm bekommen.

      Unter diesem Dropbox-Link kann man die englische und die frei übersetzte deutsche Version des Textes abrufen:

      dropbox.com/sh/vsfpzktbebil97l…FAewiQ0h7utNf7MiR78a?dl=0

      Ich habe dieses Verfahren selber mangels defektem WLan-Modul noch nicht anwenden können, Benutzung also auf eigene Gefahr!

      Die Anleitung ist übrigens nicht für Anfänger geeignet, dazu ist sie nicht ausführlich genug.
      Man sollte wissen, an welchem Ende der Lötkolben heiß wird und sich auch ein bißchen mit Windows auskennen.
      Die Anleitung behandelt aber nicht das thermische Problem der WLan.Module - wenn man das Teil schon mal auseinander hat und die Chance besteht, dass es nachher wieder funktioniert, sollte man auch gleich dieses Thema mit abarbeiten...


      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • Aus gegebenem Anlass habe ich unter dem Dropbox-Link noch drei kleine Hilfsvideos und eine Textdatei zugefügt.

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • Eine erste Erfolgsmeldung:
      Ein User (wenn auch aus einem anderen Forum, hab' das in mehreren Foren gepostet) konnte mit dieser Methode sein WLan-Modul wiederbeleben.

      Falls jemand hier mit der Methode Erfolg haben sollte, würde ich mich über eine kurze Rückmeldung freuen...

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • Moin, moin!

      Habe heute mein Wifi-Modul erfogleich mit dieser Anleitung wiederbelebt. Wenn der beschriebene Fehler vorliegt und man sich exakt an das hält was dort geschrieben steht, sollte es funktionieren. Ich habe für die benötigten Teile 20€ ausgegeben, allerdings hab ich mir auch nicht viel Mühe beim suchen nach dem günstigsten Preis gegeben :)

      Güße aus Kiel

      Alex
    • ...und noch eine Erfolgsmeldung!
      Diesmal hat es meine P2V+ erwischt - das alte Mädchen ist wohl sauer, dass ich auf Mavic umgestiegen bin...
      Keine Videoübertragung mehr - nach Flashen der Firmware alles wieder im grünen Bereich...
      Habe bei der Gelegenheit noch ein paar Fotos und Videos gemacht (auch zu den zusätzlichen Kühlmaßnahmen), die ebenfalls unter dem Dropbox-Link abrufbar sind.

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • Hallo und guten Abend,
      erstmal Danke für diese Anleitung, die ich zu meinem Leidwesen nun auch abarbeiten musste.
      Soweit habe ich alles gemäß der Anleitung absolviert. Allerdings ist das Ende meiner Prozedur anders als das Ende der Anleitungs-Prozedur.
      Ich habe das Logfile hier angehängt. Was dort zu sehen ist, läuft in einer Endlosschleife durch.
      Ist das normal ? Oder hat der NAND doch ein Defekt?
      Oder wird diese Abfolge nur angezeigt, weil das Board nicht komplett wieder verbaut ist und die erwarteten feedbacks vom restlichen System ausbleiben!?
      Kann hier jemand helfen?

      Gruß
      powerjuice


      Error: Failed to create capture device. Is video input connected?

      video.c: semkey1: 852202semkey1: 852206shmkey: -1 params->maxFrameRate ==30000

      Venc1.c : minNumOutBufs 2, minOutBu!Size[O]115200, min0utBu!Size[1]800 video.c: minNumOutBufs 2

      *osdThrFxn: process ID is786***********

      ctrlThrFxn: process ID is782***********

      ********************************************************pid of Xorg:782==783

      **************************************************************************************************************killall: enc

      ode:noprocesskilled

      [ 44.850000]cmemk unregistered

      [ 44.920000]irqk unregistered

      [ 46.160000]CMEMK module: built an Nov 27 2013 at 14:02:36 [ 46.180000] Reference Linux versinn 2.6.32

      [ 46.180000] File /home/u/dm368/dvsdk_dm368_4_02_00_06/linuxutils_2_26_01_02/packages/ti/sdo/linuxutils/cmem/src/modul

      e/cmemk.c

      [ 46.200000]allocated heap buffer Oxc7000000 of size Ox2456000

      [ 46.230000]heap fallback enabled- will try heap if pool buffer is not available

      [ 46.230000]CllEM RangeOverlapsKerne!Physical -allowingoverlap

      [ 46.240000]CllEM phys_start (Ox1000)overlaps kerne!(Ox80000000 -> Ox83000000) [ 46.250000]cmemk initialized

      [ 46.280000]IRQK module: built an Nov 27 2013at 14:02:41

      [ 46.300000] Reference Linux versinn 2.6.32

      [ 46.300000] File /home/u/dm368/dvsdk_dm368_4_02_00_06/linuxutils_2_26_01_02/packages/ti/sdo/linuxutils/irq/src/module

      /irqk.c

      [ 46.320000]irqk initialized

      [ 46.370000]EDMAK module: built anNov272013at14:02:45

      [ 46.370000] Reference Linux versinn 2.6.32

      [ 46.390000] File /home/u/dm368/dvsdk_dm368_4_02_00_06/linuxutils_2_26_01_02/packages/ti/sdo/linuxutils/edma/src/modul

      e/edmak.c pdi=831

      Encode demo started.

      [ 46.510000]davinci_resizer davinci_resizer.2: RSZ_G_CONFIG:0:1:124

      [ 46.520000] davinci_previewer davinci_previewer.2: ipipe_set_preview_config

      [ 46.520000]vpfe-capture vpfe-capture: !PIPE Chained

      [ 46.530000]vpfe-capture vpfe-capture: Resizer present detectVide to er[46.530000]vpfe_s_input

      eate

      fd=hCapture->fd

      Composite input selected

      pdi=O

      [ 46.580000]EVM: switch to tvp5151 cvbs video input

      listening.*************************************************************************************** pid of Xorg:-1==783

      ***************************************Failed toset video input to 0 (Invalid argument)

      Cannot111opencaptureDevice

      Errar: Failed tocreate capture device.Is video input connected?

      video.c: semkey1: 852202semkey1: 852206shmkey: -1 params->maxFrameRate ==30000

      Venc1.c : minNumOutBufs 2, minOutBu!Size[O]115200, min0utBu!Size[1]800 video.c: minNumOutBufs 2

      *osdThrFxn: process ID is834***********

      ctrlThrFxn: process ID is830***********

      ******************************************************* pidof Xorg:830==831

      ***********************************************

      P.S.
      Ja! Ich könnte alles zusammenbauen und einfach ausprobieren, aber da ich noch auf meine Kupferband Lieferung warte, würde ich gerne vorher alles abklären.
    • powerjuice schrieb:




      Error: Failed to create capture device. Is video input connected?
      Alles ok, das Flashen hat funktioniert!
      Die Meldung besagt, dass keine Kamera gefunden wurde (wie denn auch... :D)

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • powerjuice schrieb:


      Kann man noch irgendwas unternehmen um diese Prozedur in Zukunft zu vermeiden? Von der Sonnencreme zum kühlen mal abgesehen
      Wärmeleitpaste, Lüftungsbohrungen, Chip mit Kupferblech "füttern", Leerlauf mit stehenden Rotoren vermeiden oder für Luftstrom zur Kühlung sorgen...

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • HILFE HILFE!!!
      Hallo mein name ist Patrick und ich bin neu!
      Ich habe einen DJI Phantom 2 Version + Bekommen von meinem Onkel. Nun würde ich gerne damit ezwas Fliegen nur habe ich das Problem das ich alle Daten erhalt wlan telemetrie Daten Wlan Modul wurde gemessen funzt,Gimbal reagiert auch aber dennoch steht immer in der app Verbindung zu Ph 2 Fehlgeschlagen mac adresse findet er von der Sache. Aber nicht zu sehen wer kann mir evtl Helfen oder mir das dingen Umbauen wenn nötig. Ich Komme aus Bochum Vllt: Kommt ja jemand aus der Nähe und hat Bock einen Blutigen Anfänger zu Helfen ..... BITTE WÄRE MEGA WICHTIG.
    • So, nochmal als Nachtrag zur Ursache und "Reparatur" des "Schwarzer Bildschirm"-Problems.
      Der Text kann auch als "readme" unter dem oben angegebenen Dropbox-Link gefunden werden:


      *********************************************************************************************************************************************

      Beim Phantom 2 Vision + kommt es oft zu dem Problem, dass alles funktoniert, aber die Übertragung des Live-Videobildes ausfällt.
      Man hat dann auf dem Handy/Tablet nur einen schwarzen Bildschirm, bei Apple-Geräten erscheint noch eine ewig rotierende Ladeanzeige.

      Verursacht wird das Problem durch einen defekten Chip im Wlan-Modul des Kopters, genauer gesagt, auf der Videoplatine des Wlan-Moduls.
      Bei dem Chip handelt es sich um einen programmierbaren NAND-Chip.
      Der Defekt wird durch eine Überhitzung des Moduls verursacht, verbunden mit einem Designfehler durch DJI.
      Der NAND-Chip wird im Betrieb sehr heiß und gibt seine Wärme über das Gehäuse des Wlan-Modules ab.
      Leider hat der Chip nur eine unzureichende Anlage (manchmal auch gar keine) am Gehäuse, so dass die Wärme nur schlecht abgeführt wird und der Chip überhitzt.

      Diese Überhitzung schädigt die Speicherzellen des NAND-Chips, das darauf gespeicherte Programm startet nicht mehr -> schwarzer Bildschirm...
      Durch erneutes Flashen (Programmieren) der auf dem Chip gespeicherten Software kann dieser Fehler behoben werden.

      Grundsätzlich gilt aber, dass es sich nicht um eine richtige Reparatur handelt, sondern nur um eine Wiederherstellung. (*)

      Die Speicherzellen sind durch die Überhitzung geschädigt und es ist oft nur eine Frage der Zeit, bis der Fehler wieder auftritt.

      Man sollte daher zusätzlich zum reinen Flashen der Software auch die beschriebenen Modifikationen zur besseren Wärmeableitung durchführen.
      Man sollte auch den Kopter nicht lange ohne laufende Motoren eingeschaltet lassen, da der Luftzug der Propeller das Wlan-Modul kühlt.
      Dies erklärt auch, warum der Defekt des Wlan-Moduls oft nach einem Firmware-Update auftrat.
      Sind die Speicherzellen des NAND-Chip erst einmal geschädigt, so kann es auch vorkommen, dass der Fehler nach langer Nichtbenutzung
      des Kopters auftritt, weil die Speicherzellen des Chips ihre Ladung verloren haben.

      *********************************************************************************************************************************************

      (*) Denkt bitte daran, wenn ihr viel Geld für eine "Reparatur" des Moduls oder für ein "repariertes" Modul (EBay) bezahlen sollt!

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • Hallo zusammen, ich bin neu hier, und habe genau das Problem das der Stream dunkel bleibt. jetzt habe ich soweit alles aus gebaut und angeschlossen. jetzt bekomme ich aber nur hieroglyphen, wenn ich die 11V an schalte. Könnt ihr mir hier weiter helfen?

      Vielen dank schon mal an Kaa für die Mühe!!!

      Als Info: ich bin Elektrotechniker und arbeite derzeit in der IT, also eig sollte ich das hin bekommen! steh vermutlich nur auf dem schlauch....oder schon im WE modus :)

      als Rs232 Schnittstelle benutze ich ein normales RS232 auf usb kabel von sidecom.
      Was ich eben nicht anpassen kann ist die 3,3V wie auf dem FT232RL Adapter. Ist das ausschlaggebend?

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Tschuly ()

    • Tschuly schrieb:


      Was ich eben nicht anpassen kann ist die 3,3V wie auf dem FT232RL Adapter. Ist das ausschlaggebend?
      Wenn es nicht ausschlaggebend wäre, würde es wohl nicht explizit in der Anleitung erwähnt werden... ;)
      Besorge dir den beschriebenen Adapter, kostet bei Amazon 6 Euro

      Ich hoffe nur, du hast den Chip mit der Überspannung nicht endgültig zerstört.

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • Kaa schrieb:

      Ich habe vor ein paar Tagen einen interessanten Bericht im DJI-Forum gelesen, wonach es in einigen Fällen möglich sein soll, das WLan-Modul, bzw. das nicht mehr funktionierende Video-Board darin durch Flashen wiederzubeleben. Hört sich sehr interessant an. Es gibt dort auch eine genaue Anleitung als .pdf zur Vorgehensweise, allerdings in englisch.

      Ich habe den Verfasser des Pdf-Files mal angeschrieben und ihn gefragt, ob ich seinen Text übersetzen und verteilen darf und habe die Erlaubnis von ihm bekommen.

      Unter diesem Dropbox-Link kann man die englische und die frei übersetzte deutsche Version des Textes abrufen:
      o, Bin neu

      dropbox.com/sh/vsfpzktbebil97l…FAewiQ0h7utNf7MiR78a?dl=0

      Ich habe dieses Verfahren selber mangels defektem WLan-Modul noch nicht anwenden können, Benutzung also auf eigene Gefahr!

      Die Anleitung ist übrigens nicht für Anfänger geeignet, dazu ist sie nicht ausführlich genug.
      Man sollte wissen, an welchem Ende der Lötkolben heiß wird und sich auch ein bißchen mit Windows auskennen.
      Die Anleitung behandelt aber nicht das thermische Problem der WLan.Module - wenn man das Teil schon mal auseinander hat und die Chance besteht, dass es nachher wieder funktioniert, sollte man auch gleich dieses Thema mit abarbeiten...


      Gruß Ingo
      Hallo Ingo, bin seit heute auch hier angemeldet. Meine Frage ist, ob sich diese Anleitung auch für das Flashen des Wlan Moduls einer Phantom2 Vision ohne Plus eignet?
      Das Anpingen der 192.168.1.10 war nicht möglich.
      Eignen sich die Dateien in der Dropbox auch für die Vision (!! OHNE+)??

      Leider habe ich dazu keine Einträge in der SUFU gefunden.
      Gruß Kogara
      Bilder
      • Ping Test.PNG

        176,08 kB, 603×768, 9 mal angesehen
    • Kogara schrieb:

      Hallo Ingo, bin seit heute auch hier angemeldet. Meine Frage ist, ob sich diese Anleitung auch für das Flashen des Wlan Moduls einer Phantom2 Vision ohne Plus eignet?Das Anpingen der 192.168.1.10 war nicht möglich.
      Eignen sich die Dateien in der Dropbox auch für die Vision (!! OHNE+)??

      Leider habe ich dazu keine Einträge in der SUFU gefunden.
      Gruß Kogara
      Für die Phantom 2 Vision ist das Verfahren leider nicht geeignet...

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?
    • Kogara schrieb:

      Sind die Module für VISION und Vision+ unterschiedlich? Wo bezieht man dieses Modul am besten?
      Gruß Kogara
      Die Phantom 2 Vision hat kein separates WLan-Modul, die entsprechende Elektronik befindet sich im Kamera-Ei. Du müsstest also die komplette Kamera austauschen...

      Gruß Ingo
      Wenn 3 Leute in einem Raum sind und 5 gehen raus, wie viele müssen dann wieder reingehen, damit keiner mehr drin ist?