Tricopter mit Omnibus F4 Pro Heck-Servo funzt nicht

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    ACHTUNG: In Deutschland muß Deine Drohne per Gesetz mit einem Drohnen-Kennzeichen versehen sein! Diese Plakette muß feuerfest sein und Deinen Namen und Anschrift enthalten. Ein passendes Kennzeichen bekommst Du hier.

    • Tricopter mit Omnibus F4 Pro Heck-Servo funzt nicht

      Moin,
      ich baue mir gerade einen Tricopter wie folgt auf
      Frame: selbstgedruckt in PLA ( Bei Erfolg später neu in PETG - ist haltbarer)
      Motoren: 3x F15846 JMT Mini Multi-rotor 1806 2400KV CW Brushless Motor for DIY 2-3S 25
      ESC: Racestar Blheli-s 20A
      FC: Omnibus F4 Pro V3 mit triflight 0.7
      Empfänger: OrangeRX SBus GR400F von HobbyKing
      Servo: TowerPro MG90S

      Meine Frage: wie/wo muss ich den Servo anschließen, damit er angesprochen wird und was muss ich in Betaflight einstellen?
      Vergeblich versucht habe ich es am Anschluss für den 4. Motor (PWM4). Ich hatte angenommen, dass der mit triflight als Servo angesteuert wird. Ich habe dort (und auch an PWM1-3) keine 5V anliegen. Muss ich dafür irgendwo eine Lötbrücke setzen?
      Alles andere läuft, nur eben der blöde Servo nicht. Mit Servotester geprüft und Servo ist heil.
      Ich wollte nicht alles wieder in die Ecke schmeissen und wieder 10 Jahre (Link) warten ;( Also, wer kann mir bitte helfen?
    • Moin!

      john.hawk schrieb:

      Vergeblich versucht habe ich es am Anschluss für den 4. Motor (PWM4). Ich hatte angenommen, dass der mit triflight als Servo angesteuert wird. Ich habe dort (und auch an PWM1-3) keine 5V anliegen. Muss ich dafür irgendwo eine Lötbrücke setzen?
      Verschiedene Quellen im Netz (Suche nach "omnibus F4 pro tricopter") führen die Plus-Leitung des Servos auf einen extra BEC oder ein PDB. Ob man das auch mit einer Lötbrücke lösen kann, ist mir leider nicht bekannt.

      Grüße und viel Erfolg,
      Diet
      Mein Hangar:
      DJI Mavic Pro mit iPhone 6s, Parrot Disco, DJI F450 FlameWheel mit Naza-M V2 und FrSky Taranis, diverses "Kleinvieh" mit vier Propellern
    • Aah! Cool, das werde ich mal probieren die sind direkt neben dem Befestigungsloch an der Ecke. Entweder das, oder mit PDB. Heute sind grade welche von Matek eingetrudelt. Deine Idee mit RAM / 5V brücken finde ich persönlich besser, da ich nicht alles umbauen muss. Ich versuch‘s mal und berichte.

      Danke erstmal und Gruß
      jh
    • So, jetzt mal ein kleiner (noch unbefriedigender) Zwischenstand:
      Ich habe auf der Unterseite RAM und 5V (J3) gebrückt. Einen BEC verwende ich damit erstmal nicht. Somit habe ich jetzt Spannung (u.a.) an J12, den ich für den Servo verwende. Leider habe ich aber noch keine Reaktion am Servo.

      Falls es hilft, hier meine Resources aus dem Triflight dump:

      # Triflight 0.7 Beta 2 / OMNIBUSF4SD 3.1.7 Jun 4 2017 / 13:37:25 (1698ba5)

      # name
      name Y-Copter

      # resources
      resource BEEPER 1 B04
      resource MOTOR 1 B00
      resource MOTOR 2 B01
      resource MOTOR 3 A03
      resource MOTOR 4 A02
      resource MOTOR 5 A08
      resource MOTOR 6 NONE
      resource MOTOR 7 NONE
      resource MOTOR 8 NONE
      resource MOTOR 9 NONE
      resource MOTOR 10 NONE
      resource MOTOR 11 NONE
      resource MOTOR 12 NONE
      resource SERVO 1 A01
      resource SERVO 2 NONE
      resource SERVO 3 NONE
      resource SERVO 4 NONE
      resource SERVO 5 NONE
      resource SERVO 6 NONE
      resource SERVO 7 NONE
      resource SERVO 8 NONE
      resource PPM 1 B08
      resource PWM 1 B08
      resource PWM 2 B09
      resource PWM 3 C06
      resource PWM 4 C07
      resource PWM 5 C08
      resource PWM 6 C09
      resource PWM 7 NONE
      resource PWM 8 NONE



      Was muss ich in Triflight bei "Servos" einstellen? Übrigens bei "Motoren" rechts, habe ich bei Servos einen Ausschlag bei Servo 6, wenn ich den Copter um die Hochachse (Yaw) drehe. Ich hoffe, das hilft.

      Ich hätte nicht gedacht, daß das so kompliziert ist, sondern dass es mit der Triflight Firmware alles schön voreingestellt ist. Hätte mich wohl doch mehr auf den Quad konzentrieren sollen. :(
    • Sry, von Triflight null Dunst.

      Dennoch, Du müsstest in den resources den entsprechenden Pin als SERVO zuweisen.
      Z.Bsp. ist Pin A01 einem Servo zugewiesen. Aber welcher Anschluß das am FC ist, kann ich im Moment nicht sagen.
      Evtl. googelst Du mal danach.

      Oder eben wie beschrieben, einen MOTOR-Pin als SERVO definieren.
    • Vom Prinzip ist ja TF nunmehr ein "Ableger" von BF.
      Ob die Befehle die gleichen sind, vermag ich nicht zu sagen.
      Lies Dich einfach mal hier ein, um die Grundlage für das Mapping zu bekommen.

      github.com/betaflight/betaflig…rvos-&-SERVO_TILT-for-3.1

      Tja und dann, dann einfach mal nach TF googeln.

      Ob Du aber dann mit Deinem Clone-FC an's Ziel kommst, ohne große Messarbeit, steht wieder auf einem anderen Blatt.
      Ein Umflashen auf BF ist auch da nicht unbedingt von sofortigem Erfolg gekrönt (siehe Klimmzug bzgl. 5V).