Reaktionsloser FC

    • Sonstiges / andere

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    ACHTUNG: In Deutschland muß Deine Drohne per Gesetz mit einem Drohnen-Kennzeichen versehen sein! Diese Plakette muß feuerfest sein und Deinen Namen und Anschrift enthalten. Ein passendes Kennzeichen bekommst Du hier.

    • Reaktionsloser FC

      Huhu hab jetzt zum 2. mal das Problem das mein FC (Betaflight F4, keine Nachmache) nach anschließen des Lipo's(3s) das programm am PC sich aufhängt und die Verbindung zum FC trennt, die LED's auf dem FC erlöschen und keinerlei Reaktion mehr zeigt. Die Komponenten wie der Empfänger(XM+) als auch die Motoren bzw ESC's(Airbot Wraith32 V2) zeigen eine Reaktion durch leuchtende LED's(Empfänger) bzw piepen der Motoren oder aufleuchten der ESC's. Wie gesagt das Problem entstand erst nach Anschluss des Lipos, mit dem USB-port hatte ich davor Zugriff auf den FC danach nichts mehr(Pc,Kabel,USBport am Pc oder sonstiges ist noch in Ordnung). Jedoch habe ich bemerkt das 2 Motoren keinen Piepton erzeugten und die Kabel genauso wie die anderen Motoren gelötet waren. Kann es nun sein das wegen den Kabeln zwischen Motor und ESC aufgrund der unterschiedlichen Drehrichtung ein Kurzschluss verursacht wurde wodurch der FC nicht mehr funktioniert? Die beiden stillen Motoren erzeugten nach tauschen der äußeren Kabel nun wieder einen Ton. Die anderen Lötstellen hab ich bereits mehrfach überprüft aber die scheinen in meinen Augen kein Problem darzustellen (Empfänger sonst noch nichts)

      Hoffe das die Informationen ausreichen und auf sonstigen Foren bzw GitHub habe ich leider nichts gefunden :S

      The post was edited 1 time, last by TTB ().

    • Hi hast du’s schon versucht im DFÜ Modus Betaflight neu zu flashen?
      Hatte auch mal so ein Verhalten bei einer iNAV FW Version.
      Auch wären einige Sreenshots hilfreich so wie die Info welches Target du auf deinen FC geflasht hast.
      Plus an Masse, das knallt Klasse!
    • Kann leider nichts mehr flashen da passiert nichts mehr wenn ich den FC mit meinem PC verbinde mit dem USB Kabel weder eine LED noch verbindet es sich :(
      Da wird nichtmal mehr was angezeigt vonwegen Gerät verbunden oder so einfach keine Reaktion mehr(PC und seine Dinge funktioniert einwandfrei also daran legts definitiv nicht)
    • Nein also definitiv kein PC oder Treiber Problem es muss am FC liegen... Ich habe eine Vermutung aber meiner Erfahrung nach ist das normalerweise relativ egal... Meine Vermutung: Falsche Verkabelung zwischen ESC und Motor (die 2 äußeren Kabel der 3 Kabel vertauscht???) Bisher war das Ei meinen anderen Esc relativ egal solange die Mitte in der Mitte ist aber die Kabel vertauscht angelöten zerstören doch niemals mein FC oder liege ich da falsch??
    • Du hast nicht zufällig den 3S Akku direkt an den F4 angeschlossen also ohne BEC um 5V zu bekommen?

      Um die Einstellungen in Betaflight zu tätigen brauchst du nur den USB. Wenn du einen BEC und den Akku dran hast würde ich die USB Strippe immer abziehen. Könnte Probleme geben von wegen 5V Einspeisung in den PC. Da ging schon manche USB-Schnittstelle kaputt.
      Gruß vom Nobier
      Nicht wundern meine Tastatur verliert ab und zu Buchstaben

      The post was edited 1 time, last by Nobier ().

    • Also: In Betaflight gibt's ja den Menü Teil in dem man die Motoren einzel drehen lassen kann. Dafür benötigt man ja den Akku. Der Akku ist direkt mit + bzw - an dem FC (Mit Stecker). Um in BF die Motoren zu testen muss man ja den FC mit USB als auch dem Akku verbinden. Und hier kommen wir zur Explosion: USB ist dran, Akku dran gesteckt -> BF-Programm stürzt ab, Die Rote bzw Blaue LED geht aus(und nie mehr wieder an seit dem).

      Nur USB anschließen -> Es passiert absolut gar nichts mehr
      Nur Akku -> Motoren piepen, keine FC LED an (Blau/Rot)
      USB und Akku -> Motoren piepen, keine FC LED an (Blau/Rot)

      Wenn ich den Empfänger mit dem FC verbunden habe leuchtet dieser sowohl bei USB als auch Akku Verbindung auf aber es lässt sich nichts über die Fernsteuerung ansteuern :( (Ja die beiden sind gebunden miteinander)

      Keine defekte Schnittstelle, Treiber, Kabel o.ä(scheinbar bis auf den FC eben :( ).
    • TTB wrote:

      Also: In Betaflight gibt's ja den Menü Teil in dem man die Motoren einzel drehen lassen kann. Dafür benötigt man ja den Akku.

      Und hier kommen wir zur Explosion: USB ist dran, Akku dran gesteckt -> BF-Programm stürzt ab, Die Rote bzw Blaue LED geht aus(und nie mehr wieder an seit dem).
      Ok, hast recht mit dem Motortest aber so wie du schreibst ist der F4 denke ich mal hinüber. Du solltest alles ablöten und nur versuchen mit USB zu betreiben. Sollte da auch nichts mehr funktionieren ist der definitiv hin.
      Ich denke an einer Stelle gibt es eine Verbindung zwischen dem Akku und der BEC 5V Versorgung oder aber der BEC wird überlastet.
      Gruß vom Nobier
      Nicht wundern meine Tastatur verliert ab und zu Buchstaben
    • An den 5V Outputs lassen sich 5v bei Anschluss mit dem Akku messen. Gibt's da ne Weg zu testen ob der bec wirklich überlastet ist bzw wie kann ich das verhindern? Ich bin mir sehr sicher daß ich nur an den einzelnen Punkten angelötet hab und da keine Verbindung zwischen 2 ist.

      Edit: als ich anfangs Led's über die dafür vorgesehene Stelle angelötet hab (welche auch funktionierten mit der Konfiguration in BF beim 1. Versuch hatte ich keine Motoren bzw Esc's angeschraubt und ich hatte den Akku mit dem USB gleichzeitig dran und es funktionierte 1wandfrei. Jetzt frag ich mich stimmen die Verbindungen überhaupt? : GND-GND(ESC), Rx1-TX(ESC), M1,2,3,4-PWM(ESC)

      The post was edited 2 times, last by TTB ().

    • Du kommst so nicht weiter.
      Bau da Teil komplett aus und fang von vorn an. In derer Verdrahtung ist was nicht in Ordnung.

      Die LED´s brauchen übrigens eine Menge Strom. Bei voller Helligkeit ca. 60 mA pro LED also schon bei 10 LED´s 600mA. Las die gleich weg und nimm 12 V Teile in 2 Farben.

      Rx1, verwendest du überhaupt ESC´s die diesen Anschlus haben? Zum ansteuern brauchst du nur den M1 - 4 für die ESC´s Rx ist die Rückmeldung des Stromverbrauchs wenn ich mich nicht täusche.
      Gruß vom Nobier
      Nicht wundern meine Tastatur verliert ab und zu Buchstaben
    • Okay da muss ich echt mal gucken mit den LED's Danke schon mal hätte ich jetzt auch nicht gedacht :/

      Die Anschlüsse des Esc's sind: GND,Tx und Pwm
      Am FC: : GND, Rx1 und M1-4

      Habe eben GND mit GND
      Am FC Rx1 mit Tx am Esc -> Stimmt das dann überhaupt oder führt dies zum Tot des FC?
      Am FC M1-4 mit PWM am Esc -> Hier das gleiche ?
    • Tut mir ja leid aber ich habe es schon geschrieben das wir so nicht weiter kommen.

      Du kann verbinden was du willst wenn der FC bereits defekt ist wird das nichts bringen.

      Ich habe auch nur keinen org. Anschluss- Schaltplan und auch die ESC´s kenne ich nicht. Normal braucht man nur den PWM (orange) vom FC auf den ESC und evtl. den GND=Masse. Für die Motore natürlich die M+ und M- am ESC.

      Wenn es auch nicht so toll ist folge meinem Rat und fang noch einmal ganz von Vorn an damit du weißt ob das Teil noch io ist oder nicht.

      Sorry aber mehr kann ich nicht helfen.
      Gruß vom Nobier
      Nicht wundern meine Tastatur verliert ab und zu Buchstaben
    • Ursachenforschung ohne den Kopter selbst in den Händen zu halten ist nahezu unmöglich.
      Wenn kein Rauch aufgestiegen ist, ist es eher unwahrscheinlich dass du einen Kurzschluss an den Motorkabeln hattest.

      Nimm gleich mal einen anderen FC. Von den Betaflight brandings hatte ich auch schon zwei, haben mich so gar nicht begeistert. Bei einem hat der Gyro von Anfang an fehlerhafte Daten geliefert. Der andere fliegt zwar noch, verglichen mit einem Matek oder Bardwell ist der sein Geld aber nicht wert. Wenn er wesentlich günstiger wäre könnte man darüber reden. Aber für rund 50€ sollte man eigentlich erwarten können dass sich zumindest mal jemand ein paar Gedanken über das Boardlayout gemacht, und nicht einfach alle Pads in eine Ecke geklatscht hat.
      Vor allem für Anfänger kann ich den Bardwell F4 Va AIO empfehlen, der Mann hat eine bebilderte Anleitung geschrieben in der er quasi jedes einzelne Lötpad für Nicht-Elektroniker erklärt.