Welcher Empfänger für FrSky DJT-JR 2,4 GHz Sender Telemetrie Modul

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    ACHTUNG: In Deutschland muß Deine Drohne per Gesetz mit einem Drohnen-Kennzeichen versehen sein! Diese Plakette muß feuerfest sein und Deinen Namen und Anschrift enthalten. Ein passendes Kennzeichen bekommst Du hier.

    • OK.

      Zur Sicherheit habe ich jetzt einen neuen FC genommen.
      Die Lötpunkte verbunden und nur die Motoren, 5 V und den RX mit den Kabeln 5V, Ground und SBUS (grün) angeschlossen.

      Leider mit dem gleichen Ergebnis.

      Im Betaflight Konfigurator wird angezeigt, dass SBUS verbunden ist (die beiden Kringel) und ich kann auch die Motoren starten. Die Bewegungen der Steuersticks werden aber noch immer nicht angezeigt.

      Der RX ist gebunden. Nach dem Einschalten der Fernsteuerung leuchten am Empfänger die blaue und die grüne LED wobei die grüne ganz leicht flackert.

      Bin noch immer ratlos.
      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • Im Betaflight Konfigurator wird angezeigt, dass SBUS verbunden ist (die beiden Kringel)
      Was meinst du mit den Kringeln?

      Kannst du das alles abhaken:
      1. SBUS (grün) so angelötet wie in dem Diagramm das ChrisFPV gepostet hat?
      2. Neben diesem Pad die Lötbrücke bei SBUS gesetzt, und nicht bei PWM?
      3. Unter Ports beim korrekten UART "Serial RX" eingeschaltet? Die Nummern der UARTs stimmt bei manchen FCs nicht mit der Nummer der aufs Board gedruckten "RX Nummer" überein. Mal in die Doku des Boards nachschauen ob du die richtige hast.
      4. Unter Configuration SBUS ausgewählt?
    • @gsezz ich habe keine Omni F4 V3 mit der Brücke aber wie es aussieht geht das Signal vom SBUS Pin zu dieser Lötbrücke wo wenn ich die Brücke auf SBUS löte das Signal weiter über einen Inverter geht und dann erst an dem UART und bei der Nrücke PPM geht’s direkt zum URAT?

      @ledoc bitte ein Bild vom FC mit RX drauf, eines vom Config TAB im Betaflight wo wir die Empfänger Einstellungen sehen können. Und noch einer vom
      Empfänger TAP das wir sehen ob deine Kanalzuordnung auch passt.
      Plus an Masse, das knallt Klasse!
    • Ja das ist bei so einer Brücke am wahrscheinlichsten. Es könnte auch sein dass es zwischen zwei verschiedenen UARts umgelegt wird, von denen halt einer einen Inverter hat und der andere nicht. Aber bei einem F4, der eh so wenige hat, ist das unwahrscheinlich. Gewissheit müsste eigentlich der Hersteller in seiner Doku geben.
    • Und er müsste dann bei an Anschlüssen in Betaflight Empfänger am UART 6 einstellen wenn dieser Plan des FC stimmt.




      Hier wird das eigentlich gut erklärt.
      Plus an Masse, das knallt Klasse!
    • Hallo gsezz, hallo Chris,
      danke für für eure Unterstützung!

      Zu den Hinweisen von gsezz:
      Was meinst du mit den Kringeln?
      - den Serial Link Satus und der Statusleiste vom Betaflight Konfigurator. Siehe Bild 1

      Kannst du das alles abhaken:
      1. SBUS (grün) so angelötet wie in dem Diagramm das ChrisFPV gepostet hat?
      - Ja

      2. Neben diesem Pad die Lötbrücke bei SBUS gesetzt, und nicht bei PWM?
      - Ja, siehe Bild des FC (Bild 2)

      3. Unter Ports beim korrekten UART "Serial RX" eingeschaltet? Die Nummern der UARTs stimmt bei manchen FCs nicht mit der Nummer der aufs Board gedruckten "RX Nummer" überein. Mal in die Doku des Boards nachschauen ob du die richtige hast.
      - Diese Frage verstehe ich nicht. Ich habe auf Anraten von Chris das S.Port-Kabel vom Empfänger erst mal nicht am FC angelötet. Im Menü Anschlüsse habe ich für den Empfänger UART1 ausgewählt. Siehe Bild 3

      4. Unter Configuration SBUS ausgewählt?
      - ja, Siehe Bild 4

      Zu den Hinweisen von Chris:
      zu:
      @gsezz ich habe keine Omni F4 V3 mit der Brücke aber wie es aussieht geht das Signal vom SBUS Pin zu dieser Lötbrücke wo wenn ich die Brücke auf SBUS löte das Signal weiter über einen Inverter geht und dann erst an dem UART und bei der Brücke PPM geht's direkt zum URAT?
      - ich habe einen anderen FC genommen und die Brücke gelötet. Siehe Bild 2

      zu:
      @ledoc bitte ein Bild vom FC mit RX drauf,
      - siehe Bild 2
      eines vom Config TAB im Betaflight wo wir die Empfänger Einstellungen sehen können.
      - siehe Bild 4
      Und noch einer vom Empfänger TAP das wir sehen ob deine Kanalzuordnung auch passt.
      - siehe Bild 3







      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • chrisfpv wrote:

      Und er müsste dann bei an Anschlüssen in Betaflight Empfänger am UART 6 einstellen wenn dieser Plan des FC stimmt.
      Ich habe es mit UART 1, 3 und 6 probiert es ging bei keinem.
      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • Und wie sieht’s beim Receiver Tab aus Ausschläge auf irgendeinem Kanal? Bild 3 ist nicht das Empfänger Tap sonder Anschlüsse
      Kanalzuordnung? Bitte noch ein Bild wo man sieht das dass grüne SBUS kabel vom RX auch auf den FC geht ich sehe da nur immer Servostecker.
      Plus an Masse, das knallt Klasse!

      The post was edited 1 time, last by chrisfpv ().

    • Ich glaube der "Serial Link Status" steht für die Verbindung zwischen USB Interface und FC. Dass das etwas mit dem Empfänger zu tun hat wäre mir neu, wird bei mir auch angezeigt wenn kein Empfänger angeschlossen ist.

      UART6 sollte der richtige für das SBUS Pad sein.


      Sind denn in der Funke den Sticks Kanäle zugewiesen? Kannst auf der Funke selbst Kanalwerte sehen, wenn du die Sticks bewegst? - Ich kenne die Turnigy leider nicht.
    • gsezz wrote:

      Ich glaube der "Serial Link Status" steht für die Verbindung zwischen USB Interface und FC. Dass das etwas mit dem Empfänger zu tun hat wäre mir neu, wird bei mir auch angezeigt wenn kein Empfänger angeschlossen ist.
      Habe gerade nicht Zugriff auf Betaflight aber ich glaube mich zu erinnern das dieses kleine Fallschirm Symbol leuchtet wenn Werte auf den Kanälen erkannt werden?
      Plus an Masse, das knallt Klasse!
    • Hallo zusammen,
      ich war heute Abend mit meinem Copter bei einem Bekannten. Wir haben einen anderen Empfänger und einen anderen Sender getestet und damit wurden die Ausschläge der Sticks im Konfigurator angezeigt.
      Der Empfänger liegt auf UART 6.

      Das grüne Kabel vom Empfänger ist auf jeden Fall richtig am SBUS-Pin des FC angeschlossen. Daran liegt es definitiv nicht.

      Das Problem liegt also nicht am FC sondern an der Übertragung. Da ich bisher noch nie mit solchen Sendern und Empfängern gearbeitet habe kenne ich mich damit nicht aus. Ich werde noch mal genau nachlesen, wie man die Kanäle genau zuordnet und was man einstellen muss, damit das an den FC übertragen wird. Der Turnigy 9XR Pro mit OpenTX und dem XJT-Modul war sicher keine sehr gute Wahl als Einsteigerfernsteuerung. Ich habe mich da zu sehr von einem Vergleichstest leiten lassen.
      Leider gibt es kaum Beschreibungen oder Handbücher für diese Kombination.

      Vielen Dank für eure Hilfe und einen schönen Abend!
      Alles kann, nix muss.
      Spaß bringt gute Laune.

      The post was edited 1 time, last by ledoc ().

    • Damit kommt man dich schon mal weiter. Gehen muss diese Kombi habe auf YouTube Anleitungen gefunden. Diese hier ist recht gut erklärt? Ist zwar ein Multiprotokoll Modul aber es ist auf deines Anwendbar.
      Ab 8 min. wird gezeigt wie man das Protokoll auswählt und die Kanäle in Mixer einrichtet.



      Mache mal Bilder von dieses Einstellungen bei Dir.
      Plus an Masse, das knallt Klasse!
    • Hi Chris,
      vielen Dank! Genau so eine Anleitung habe ich gesucht. Ich denke, damit bekomme ich die Fernsteuerung eingestellt. Das werde ich aber erst morgen machen.
      Gute Nacht!
      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • Hi zusammen,

      es klappt!!!

      Zuerst habe ich wieder die 9xr Pro Firmware in der aktuellen Version aufgespielt. Danach machte der Sender das, was im Video beschrieben ist. Ich denke, dass ich erst mal auf die OpenTX verzichte, bis ich mich besser mit dem Sender und seinen Möglichkeiten auskenne.
      Dann bin ich genau nach der im Video beschriebenen Methode vorgegangen. Ich musste nur das entsprechende externe Sendermodul auswählen.

      Ergebnis: Die Steuersignale werden über den Empfänger auf den Copter übertragen.

      Jetzt muss ich nur noch einen Kanal fürs armen auswählen und den Sender entsprechend programmieren.
      Ich denke, dann kann ich den Copter mit dem Sender steuern.

      Als nächstes kommen dann die Propeller dran und ich will das Ding in der Luft sehen!

      Nochmals vielen, vielen Dank für die Unterstützung von Chris und gsezz!
      Wenn ich so weit bin und mal zu einem Copter-Event fahre, hoffe ich euch mal zu treffen und dann gehen die Biere (auch alkfree und Softdrinks) auf mich.

      :) :) :)
      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • Hallo zusammen,

      leider läuft es nicht immer so, wie man es sich erhofft. Murphy eben!

      Nachdem ich in den letzten zwei Wochen wegen eines anderen zeitintensiven Projektes nicht weiter am Copter schrauben konnte, habe ich ihn am Pfingstwochenende wieder hervorgeholt und wollte dort ansetzen, wo ich aufgehört hatte.

      Leider gab es wieder Probleme mit den Steuersignalen.
      Sie werden nur manchmal übertragen, reagieren teilweise zeitverzögert und der Copter läst sich nicht armen.

      Nach intensiven weiteren Studien und probieren verschiedener Einstellungen habe ich...
      - die 3V Knopfzelle des Senders gewechselt
      - die Kontakte des Sendermodules geprüft
      - Betaflight auf einem anderen Notebook installiert
      - Sender- und Flugakku geladen
      - den Sende nochmals komplett programmiert
      - und mein Glück versucht.

      Im Betaflight Configurator unter Empfänger und PID Einstellungen werden die Eingaben des Senders nicht zuverlässig dargestellt. Da ich nicht überprüfen konnte, ob es am Sender oder am Empfänger lag, habe ich die Nerven verloren und gestern Abend bei Amazon einen neuen Sender mit Empfänger bestellt.

      Im das Problem hier noch einmal genau beschreiben zu können, habe ich den Copter heute nochmal am Betaflight Configurator angeschlossen und den Sender eingeschaltet und ….
      heute Funktioniert er ohne Probleme. Keine Ahnung was war.

      Ich habe also noch einmal alle Einstellungen am Sender vorgenommen und das "arming" auf den Dreifachschalter gelegt.
      Mixer
      Chanal 5 0 Full ID-
      + -100 Full ID(Pfeil nach unten)
      + 100 Full ID(Pfeil nach oben)

      Chanal 13 100 Thr (warum auch immer????)

      Unter Safety Switches
      Ch3 X Thr -100 Thr

      Im Betaflight Configurator unter Empfänger und PID Einstellungen werden die Eingaben des Senders jetzt problemlos angezeigt. Beim Betätigen des 3-fach-Schalters werden die unterschiedlichen Were angezeigt.
      Beim Einschalten des Senders gehen die Anzeigen für Aux 13 und Aux 14 auf kleine Werte.
      Aux 9 bewegt sich parallel zu Thr.

      Nur armen geht scheinbar nicht. Der auf dem Monitor unter PID Einstellungen angezeigte Copter lässt sich bewegen
      nur die Propeller laufennicht an.

      Hier die Bilder des Betaflight Configurator:
      Images
      • PID 1.jpg

        169.25 kB, 1,024×576, viewed 8 times
      • PID 2.jpg

        166.08 kB, 1,024×576, viewed 7 times
      • Anschlüsse.jpg

        147.04 kB, 1,024×576, viewed 8 times
      • arm.jpg

        186.85 kB, 1,024×576, viewed 4 times
      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • Du kannst nicht einfach armen wenn du mit USB und Betaflight verbunden bist. Du musst im Motor Tap den Schalter bestätigen das du die Probs runter hast und weis was du tust.
      Und die Pribs bitte wirklich runter. Was hast du bei Amazon genau bestellt?
      Plus an Masse, das knallt Klasse!
    • Hallo Chris,
      danke für die schnelle Rückmeldung.
      Den Schalter hatte ich schon umgelegt. Hab aber noch mal den Sender Überprüft und den zusätzlichen Chanel rausgenommen und den Safetyswitsch-Eintrag gelöscht. Jetzt laufen die Motoren am Copter endlich an.
      Im Betaflight Configurator aber noch nicht.

      Der Sender meldet sich auch mit der akustischen Fehlermeldung: "Receiver Signal critical"
      Da muss ich noch mal checken.

      Ich habe mir gestern als Zusatzfunke eine FlySky FS I6s mit einem IA6B und einem zusätzlichen FS A8s-Empfänger bestellt.

      Jetzt habe ich noch Probleme mit einem Motor, der nur mit geringerer Drehzahl läuft. Dazu aber dann mehr in meinem Projekt Baubericht.

      Zumindest sehe ich jetzt Licht am Ende des Tunnels. Wenn ich noch genug Zeit finde, bekomme den ersten Copter hoffentlich noch bis zum Wochenende in die Luft. Dann kann ich ihn mit in den Urlaub nehmen und an meinen Flugfertigkeiten arbeiten.
      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • Bei FrSky immer mehr als 1 Meter zwischen TX und RX einhalten sonst kommen die Telemetrie Warnungen.
      Plus an Masse, das knallt Klasse!
    • Danke für den Hinweis.

      Ich muss noch viel lernen.
      Je mehr man von einer Sache weiß, desto mehr weiß man, dass man nichts weiß.

      Schönen Abend!
      Alles kann, nix muss.
      Spaß bringt gute Laune.
    • Der erste Copter macht noch Motorprobleme. Aber die gute Nachricht: Die Funke läuft und ich kann den Copter armen und alle Steuerfunktionen laufen so, wie es soll.
      Muss wohl für den kleinen erst noch andere Motoren besorgen.

      Ich habe daher aus anderen Teilen schnell einen 250er zusammen gebaut. Hat auch flott geklappt und er war auch schon in der Luft. Er ist aber auch noch nicht optimal. Die Motoren sind zu schwer und brauchen daher mindestens einen 4s LiPo. Damit ist er aber eine fliegende Kreissäge.
      Muss also auch für diesen Copter noch andere Motoren kaufen.

      Die neue Funke habe ich daher noch nicht ausgepackt. Schaffe ich auch vor dem Urlaub nicht mehr.
      Auch der Baubericht für den zweiten Copter muss daher noch bis nach dem Urlaub warten.

      Ich wünsche allen Copter-Schraubern und Piloten einen schönen Restjuni und bedanke mich vor allem bei Chris und gsezz für die Geduld und Unterstützung.

      Rene
      Alles kann, nix muss.
      Spaß bringt gute Laune.