Neuen Quad gebaut - keine Ausschläge in BF

    ACHTUNG: Mit der neuen EU Drohnenverordnung muß sich jeder Drohnen-Betreiber beim Luftfahrtbundesamt registrieren und seine Drohne mit der e-ID kennzeichnen! Ein passendes Kennzeichen bekommst Du hier im Shop. Außerdem benötigst Du eine Drohnen-Versicherung. Hier geht es zu unserem Drohnen-Versicherungsvergleich. Informationen zum neuen EU Drohnenführerschein gibt es hier.

    • Neuen Quad gebaut - keine Ausschläge in BF

      Hallo,

      ich bin Finn und habe mir for 6 Jahren meine erste Drohne zusammengebaut. Dann habe ich mich recht lange nicht mit dem Thema auseinandergesetzt und bin daher jetzt wieder recht neu in dem Thema (da hat sich einiges getan). Ich habe mir jetzt eine kleine <250g Drohne zusammengestellt, komme aber leider nicht bis zum Jungfernflug.
      Als FC nutze ich den ZEUS F722 mini, als ESC den HAKRC 8B35A und als Empfänger einen R-XSR. Ich habe einige Hürden meistern müssen, es hat beispielsweise etwas gedauert, bis ich herausgefunden habe, dass die Verbindung FC-ESC nicht genormt ist. Jetzt habe ich es aber.
      Ich bin jetzt soweit, dass ich den FC über Betaflight einstellen kann, auch die Motoren lassen sich über BF ansteuern.
      Den Empfänger habe ich auch an meine Funke (Taranis X9d Plus, die alte) gebunden. Am Empfänger leuchten sowohl die grüne als auch die blaue LED und die Taranis zeigt auch Telemetrie an bzw. gibt Bescheid, wenn die Telemetrie verloren geht. D.h. aus meiner Sicht steht grundsätzlich die Verbindung Funke-Empfänger.
      Jetzt zu meinem Problem:
      Ich bekomme keine Ausschläge in Betaflight, wenn ich die Sticks bewege. In diversen Foreneinträgen habe ich Tipps zur Verkabelung und auch zur Firmware gefunden und auch die Möglichkeit, SBUS oder F-Port zu nutzen.
      Zur Verkabelung:
      Den R-XSR habe ich gemäß Anleitung angeschlossen, Also GND, 5V und SBUS Out an UART1, den S-Port an UART3.



      Im Anschlüsse Tab den UART3 dann auf Smartport gestellt, UART1 auf serieller Empfänger.


      Die Taranis hat ein neues OpenTX (2.3), das XJT Modul hatte ich zwischenzeitlich auf "XJT_ACCST_2.1.0_LBT" und den Empfänger entsprechend auf "RXSR_ACCST_2.1.0_LBT" und testweise auch "RXSR_ACCST_2.1.1_Fport_LBT" geflashed. Dies hat nicht funktioniert. Ich habe dann gelesen, dass es zu Problemen mit der 2.1 kommen kann und habe dann das XJT Modul auf "XJT_EU170317" und den Empfänger abwechselnd auf "RXSR_LBT_ACCST_191112" und "RXSR-FPORT_LBT_ACCST_191128" geflashed, leider auch ohne Erfolg.
      In Betaflight habe ich abwechselnd je nach Firmware dann im Bereich Konfiguration entweder SBUS oder FRSky FPORT ausgewählt und auch mit diversen Kombinationen im CLI der Einstellungen "serialrx_halfduplex" und "serialrx_inverted" herumprobiert, leider war auch dieses ohne Erfolg.

      Jetzt hoffe ich, dass ihr vielleicht noch den einen oder anderen Tipp habt, vielleicht seht ihr noch einen Fehler, der mir entgangen ist. Wie gesagt, ich bin recht neu in der Thematik und hoffe, das es vielleicht nur eine Kleinigkeit ist, die mir entgangen ist.

      Herzliche Grüße aus dem Norden
      Finn
      Images
      • IMG_1337.JPEG

        70.3 kB, 576×768, viewed 168 times
      • Konfiguration.JPG

        53.66 kB, 1,024×308, viewed 82 times
    • Konzentriere Dich erst mal darauf, das System mit SBUS zum Laufen zu bringen. Flashe den Empfänger wieder mit RXSR_ACCST_2.1.0_LBT als SBUS-Version und dann stellst Du auch unter "serieller Empfänger" SBUS ein. Bist Du sicher dass Du den "SBUS Out" auch tatsächlich am Rx von UART 1 angeschlossen hast?
      Den S-Port lasse mal unbeschaltet.
      Und wird der Empfänger überhaupt mit Strom versorgt wenn der FC an USB hängt? Oft ist das nicht der Fall und dann muss zusätzlich ein Flugakku ran.

      Gruß Gerd
    • Hi Gerd,

      Empfänger habe ich auf RXSR_ACCST_2.1.0_LBT geflashed, das XJT Modul ebenfalls auf 2.1.
      Serieller Empfänger und SBUS sind in BF eingestellt, ich habe auch den Smart Port an UART3 sowohl am Board als auch in BF entfernt.
      Der Empfänger bekommt Strom über den USB vom FC. Blaue und grüne LED sind beide an.
      Leider nach wie vor kein Erfolg.

      VG Finn
    • So, Problem ist gelöst. Ich habe den Quad in BF auf Werkseinstellungen zurückgesetzt und dann ging es. Welche Einstellung da letztenendes jetzt verhindert hat, dass das Signal durchgeht, weiß ich leider nicht.
      Vg
    • Hallo Finnchi. ich habe deine Beitrag hier gefunden.
      Deine Aussage "Ich habe einige Hürden meistern müssen, es hat beispielsweise etwas gedauert, bis ich herausgefunden habe, dass die Verbindung FC-ESC nicht genormt ist. Jetzt habe ich es aber."
      ich habe wohl das gleiche Problem.... V und Gnd waren vertauscht. mein Smoker hatte einen Kurzschluss angezeigt. nun bin ich max. verwirrt wegen der Anschlüsse. Fc CRNT + R6 und ESC CURR + NC !!
      Was gehört wohin?
      FC: Zeus 722 mini
      ESC: HAKRC 8B35A

      Hier die Anschlüsse:


      Danke für euren Tipp.

      michel
    • Nc steht für "not connected" oder "no connection" , den brauchst du nicht belegen.
      CRNT und CURR stehen für current = Strom, darüber läuft die Stromermittlung. Die beiden also verbinden.
      R6 bleibt unbelegt.

      Kann aber gut sein dass der FC nicht mehr läuft wenn er schon mal verpolt angeschlossen war. Manche FCs mögen das nicht.