Keine Akkustandanzeige-Übermittlung / Telemetrie // TBS Tango2 mit TBS Nano RX

    ACHTUNG: Mit der neuen EU Drohnenverordnung muß sich jeder Drohnen-Betreiber beim Luftfahrtbundesamt registrieren und seine Drohne mit der e-ID kennzeichnen! Ein passendes Kennzeichen bekommst Du hier im Shop. Außerdem benötigst Du eine Drohnen-Versicherung. Hier geht es zu unserem Drohnen-Versicherungsvergleich. Informationen zum neuen EU Drohnenführerschein gibt es hier.

    • Keine Akkustandanzeige-Übermittlung / Telemetrie // TBS Tango2 mit TBS Nano RX

      Hallo Zusammen,

      nach Eurer Hilfe - daß ich die Nazgul überhaupt zum fliegen gebracht habe - stehe ich schon wieder vor der nächsten Herausforderung.
      Ich bekomme keine Akkuspannung des Fluglipos auf der Tango 2 angezeig. (noch irgendwelche anderen Daten...)
      Somit kann ich keinen Alarm an der Funke ausgeben damit ich weiß wann gelandet werden muss.

      Auch bei der Funke steht unter Telemetrie nur "default" und kann nichts anderes ausgewählt werden.






      Verlötet habe ich den Nano X RX Empfänger von wie hier im Bild also von Ch2(TX) auf TX vom FC und RX (Ch1) auf RX vom FC


      Hab ich was falsch gemacht oder muss ich ggf. nach mehr anschließen ?
      Haben ist besser als brauchen...
    • RX und TX müssen immer über kreuz angeschlossen werden. Immer TX (T = transmit = senden) an RX (R = receive = empfangen)

      In Betaflight unter Configuration die Telemetrie aktivieren, das ist normalerweise default. Und dann an der Tango "discover new Sensors" ausführen.
      "If I go home with a single Drone still working, I have not done my Job."
      - Botgrinder 2021
    • Hi gsezz,

      bin jetzt mal an der Funke auf "discover new Sensors" gegangen und da wurden mir dann plötzlich alle möglichen Daten ausgespuckt.
      Von daher müsste ich den Empfänger korrekt verdrahtet haben, oder ?
      Haben ist besser als brauchen...
    • Nicht unbedingt. Auch ohne Verbindung zum FC überträgt der Empfänger seine eigene Telemetrie, z.b. LQ und RSSI Werte. Die Lipospannung wird aber nur auftauchen wenn die Verbindung zu Betaflight funktioniert.
      "If I go home with a single Drone still working, I have not done my Job."
      - Botgrinder 2021
    • Nummer 14 ist doch die Lipo Spannung, oder ?




      Daru - im OSD wird mir außer "keine Aufnahme möglich" nix von den in Betaflight eingestellten Dingen angezeigt..


      Da fällt mir aber gerade noch was ein:
      Im Menü der Tango kann man ja auch ins Betaflight setup gelangen. Wenn ich das anwähle passiert aber bei mir nichts. (die Funke bleibt einfach so und lässt sich nur durch ausschalten wieder benutzen)
      Steht dann die ganze Zeit auf initialising - Pls connect RX & FC
      Dies müsste/könnte das Indiz der falschen Verdrahtung sein, oder ?
      Haben ist besser als brauchen...

      The post was edited 4 times, last by Styx_73 ().

    • Die Telemetrie scheint zu funktionieren, die sichtbaren Werte kommen fast alle von Betaflight. RxBT sollte deine Lipospannung sein.

      Das Menü auf der Tango ist ein LUA-Skript, und vermutlich passt dessen Version nicht zur Betaflight Version. Ich bin aber auch nicht so ganz auf dem Laufenden wie das momentan bei der Tango funktioniert, weil die ja nicht OpenTX/EdgeTX benutzt, sondern den hauseigenen Fork FreedomTX. Bei mir funktioniert es noch, und ich kann mich nciht erinnern dass ich das Skript manuell installiert hätte. Eventuell musst du mal die Tango updaten.

      Was für ein Videosystem benutzt du denn?
      "If I go home with a single Drone still working, I have not done my Job."
      - Botgrinder 2021

      The post was edited 1 time, last by gsezz ().

    • Styx_73 wrote:

      Daru - im OSD wird mir außer "keine Aufnahme möglich" nix von den in Betaflight eingestellten Dingen angezeigt..
      Geh mal im Brillenmenu auf Einstellungen -> Display -> OSD Anpassen und stelle den Wert auf "ein".
      Danach wird das OSD von BF verwendet (es gehen aber nicht alle Werte die BF anbietet)

      Ohne diese Option solltest du zumindest die Spannungsanzeige des Kopters im Bild haben.


      Wenn in diesem Feld kein Wert eingetragen ist stimmt etwas mit deinem UART nicht. Der ist dann entweder nicht aktiviert
      oder RX u. TX wurden falsch angelötet.
    • Hallo,

      sorry - hab diese Woche Spätschicht deshalb kann ich jetzt erst weiter machen...

      gsezz: Ich benutze ne RunCam mit DJI Goggle (ich hoffe das reicht als Info ?)

      Daru: Hab jetzt mal (so gut es ging) ein Foto von dem OSD gemacht.


      Habe in den Einstellungen der Brille das OSD auf "ein" gestellt - jedoch ohne Veränderung...

      Ich werd jetzt mal den Lötkolben anwerfen und TX und RX umlöten...
      Haben ist besser als brauchen...
    • OK - umgelötet jedoch kann ich dann weder die Motoren starten noch hab ich Telemetriewerte jenseits der # 10

      Von demher war der RX schon richtig verlötet...
      Haben ist besser als brauchen...
    • Nicht RX u. TX vom Crossfire Empfänger umlöten sondern von der Vista/AirUnit/Runcam.

      Die Telemetrie die du auf der Tango siehst kommt direkt vom Crossfire Empfänger die er aus dem FC ausliest. Das gleiche brauchst du auch bei der Vista/AirUnit/Runcam.
      Ohne einen korrekten Anschluss bleibt die Vista/AirUnit/Runcam auch in einem LowPower Modus, d.h. weniger Sendeleistung, Bildwiederholrate und die automatische
      Aufnahme startet auch nicht.
      Wenn du armst muss in der Brille ein rotes Rechteck aufploppen( Meldung:"Freigeschaltet"), dann läuft alles.
    • Hi Daru - was für ein Sch...

      Kabel wieder zurück gelötet (wie es vorher war) und plötzlich zeigt es mir den Akku unten links und ein weißes Dreieck an.
      Haben ist besser als brauchen...
    • Spuckt mir die Brille ne Warnung aus wenn der Akkustand nen bestimmten Wert unterschreitet ? (muss ich dies im Betaflight aktivieren ?)
      Kann ich dies zuzüglich auch noch über die Funke als akkustischen Alarm ausgeben ?

      Ich muss echt zugeben - dieses Projekt bringt mich an den Rand der Verzweiflung. Ich fliege seit Jahren Fläche mit Graupner später dann Spektrum.
      Von den Spektrum Funken habe ich mitlerweile 3 Stück (DX10 / DX6)
      Fahre X-Maxx mit ner Flysky Noble NB4 (hab auch davon 3 Stück wegen den Kids ihren Autos) und nichts - aber bisher auch gar nichts war annähernd so kompliziert wie
      diese Geschichte hier.
      Mal unabhängig davon daß ich mit 49 Jahren diese blöde mini Display der Tango 2 kaum ablesen kann ist die Menüstruktur echt miserabel...
      Haben ist besser als brauchen...
    • Die Brille warnt dich nicht wirklich bei niedrigem Akkustand, weder über ihren eigenen, noch über den des Quad. Die Zahlen werden zwar irgendwann rot, aber da du nicht einstellen kannst bei welcher Spannung, und die Brille nicht weiß was für ein Akku angeschlossen ist, bringt dieses random rot werden herzlich wenig.

      Von der Funke kannst du dir Audiowarnungen ausgeben lassen. Dazu dienen die "logical switches" von OpenTX. Du erstellst dir einen Switch der aktiv wird wenn der Telemetriewert kleiner ist als "X", und dann eine Audiowarnung die von diesem Switch geschaltet wird.
      rc-soar.com/opentx/lowbatteryalert/index.htm

      In Betaflight kannst du mit diesem CLI Befehl statt der Gesamtspannung eine pseudo Zellspannung per Telemetrie übertragen lassen. Dann funktioniert der Alarm der Funke auch gleich universell mit Lipos verschiedener Zellzahlen.
      set report_cell_voltage = ON
      Auch die Brille zeigt dann die Zellspannung an, was ich eh angenehmer finde als Gesamtspannungen.


      Wenn einem das Display der Tango zu klein ist, gibt es doch unzählige andere Funken die man hätte kaufen können.
      Die Menüstruktur ist bei OpenTX eigentlich so simpel wie es nur geht: Alle Wege führen nach Rom, wenn man oft genug die Page Taste drückt.
      "If I go home with a single Drone still working, I have not done my Job."
      - Botgrinder 2021

      The post was edited 2 times, last by gsezz ().