Jumper T20 - Finger weg

    ACHTUNG: Mit der neuen EU Drohnenverordnung muß sich jeder Drohnen-Betreiber beim Luftfahrtbundesamt registrieren und seine Drohne mit der e-ID kennzeichnen! Ein passendes Kennzeichen bekommst Du hier im Shop. Außerdem benötigst Du eine Drohnen-Versicherung. Hier geht es zu unserem Drohnen-Versicherungsvergleich. Informationen zum neuen EU Drohnenführerschein gibt es hier.

    • Jumper T20 - Finger weg

      Wollte hier mal meine Erfahrungen zur Jumper T20 teilen.

      Das wichtigste vorab, alles was mit USB zu tun hat funktioniert nicht. Zum Fliegen geht Sie. Flashen oder Sim fliegen - Fehlanzeige.

      Ich hab mir eine Jumper T20 (nicht S) in der 2.4G ELRS Variante bestellt. Der Formfaktor ist sicherlich Geschmackssache aber ich finde das Ding liegt Klasse in der Hand und lässt sich halt einfach besser mitnehmen als Tx16, Boxer oder ähnliches.
      Ausgepackt angeschlossen, wollte ELRS flashen. Funke wird erkannt, Treiber passt auch, sobald man versucht irgendwas mit dem COM port zu machen verschwindet er. Verschiedene USB Kabel getestet (man sollte ja meinen das mitgelieferte funktioniert aber einen Versuch ist es wert), keine Änderung. USB-c auf USB-c funktioniert garnicht, alle anderem USB2 USB3 an verschiedenen ports - nichts. Naja gut dann halt WiFi flashen, das geht immer. Als nächstes wollte ich das Ding im Simulator testen. Leider auch kein Glück. Wird als Jumper T20 Joystick erkannt, 5 - 10 Sekunden später ist er weg. Mal den Rechner wechseln (bei der Gelegenheit von Windows 11 auf 10 gewechselt) gleiches Bild. Paar Screenshots gemacht, Retourenetikett drauf geklebt und zurück geschickt.
      1 Woche später kam der Ersatz (es ist sicher eine andere, die Retoure war noch auf dem Weg).
      Gleiches Bild. Zwischenzeitlich habe ich mit dem Gedanken gespielt EdgeTX upzudaten, aber der DFU / Bootloader Modus geht garnicht, getestet an drei verschiedenen Rechnern. Immer nur ein unbekanntes Gerät ohne Hardware oder Hersteller ID.

      Mein Fazit: Entweder ist die Qualitätskontrolle bei Jumper noch mieser als ihr Ruf und ich hab zwei defekte bekommen oder das Ding ist Müll by design. So oder so, das wars für mich erstmal mit Jumper. Die zweite geht auch wieder zurück.

      Habt ihr auch eine Jumper T20 und vielleicht ähnliche Erfahrungen?

      Beste Grüße
    • Auch wenn du es an drei PCs getestet hast, klingt das doch eher nach Software-Problemen, oder einem Benutzerfehler.

      Meine funktioniert wunderbar. Die USB-Joystickfunktion habe ich allerdings nie probiert, weil ich einen ELRS Dongle benutze.
      Beim ELRS flashen hatte ich anfangs auch Probleme mit dem USB-Passthrough, die sich aber als reiner Benutzerfehler meinerseits herausstellten. Ich hatte es auch erst unter Linux, und dann an einem Windows Rechner versucht, und bei beiden keinen Erfolg. Als ich die Fehlerquelle gefunden hatte, klappte es dann.
      Ich kann mich leider nicht mehr erinnern, was genau das Problem war. Ich glaube, letzten Endes lag es nur daran, dass die Verbindung von der Funke zum ELRS Modul in EdgeTX gar nicht mehr eingerichtet war. Ich erinnere mich ganz dunkel, dass ich aus dem Wiki die richtige Baudrate heraussuchen musste. Aber keine Ahnung wieso die Konfiguration plötzlich hops war, vielleicht hatte ich vorher EdgeTX neu geflasht, oder so. :rolleyes:

      Sonst kann ich eigentlich nur gutes berichten. Die Bedenken, die ich angesichts Jumpers Ruf hatte, hat sie völlig ausgebügelt. Ich halte die T20 für hochwertiger als meine X9D+, und mindestens gleichwertig der Tango 2, wenn man bedenkt, dass man fürs gleiche Geld mehr Funktionen bekommt.
      Ich habe sie auch bis aufs letzte Teil zerlegt, und hatte nichts zu meckern. (Außer, dass die Gehäuseschrauben keine Gewindeeinsätze haben. Bisschen uncool, wenn man sie häufiger mal zerlegen muss)
      Der "Was macht ihr alle grad" Thread
    • Um einige der Probleme kann man natürlich drum herum frickeln. Klar man muss nicht USB flashen, der Bootloader Mode geht ja. Nur dass ich leider keine Dateien auf den internen Speicher kriege, weil die Verbindung nicht lang genug hält. Und ja ich könnte einen ELRS Dongle kaufen dann ginge es auch ohne usb Verbindung. Aber das alles sollte bei einem neuen Gerät nicht nötig sein.
      Finde es auch lustig, dass bei allen Reviewern eine QC Karte in der Box lag, meinen beiden hatten das nicht. Auch die Tatsache dass sich seit dem ersten Kontakt vor nun fast zwei Wochen Null Reaktion vom Jumper Support hatte ist nicht gerade beruhigend.
    • Die Treiber sind drauf. Im VCP mode wird sie auch kurz erkannt und verschwindet dann sofort wieder. Der gleiche Rechner hat übrigens mit Radiomaster Funken keine Probleme.
      Im Bootloader mode wird sie nicht erkannt, das Gerät sendet keine Vendor und Hardware IDs also helfen Treiber an der Stelle auch nichts. Und ja sie ist wirklich im Bootloader Mode und nicht im Lademodus.
      Ich geb dem Support jetzt nochmal ne Woche, dann geht das Teil zurück. Ich wollte sie eigentlich mal aufmachen um die Gimbals anzuziehen (Throttle ist komplett lose, fällt einfach runter, sogar wenn sie flach auf dem Tisch liegt), vielleicht kuck ich mir bei der Gelegenheit das Innenleben mal an. Jumper hat ja den Ruf gerne mal ne schlechte Lötstelle zu haben.
    • Hab aktuell mit meiner Jumper T20S dasselbe Problem. Egal, in welchem Modus ich sie starte (auch dann, wenn ich den Modus sofort in z. B. SDCard starten lasse, also ohne Auswahldialog), sie verschwindet innerhalb weniger Sekunden wieder von meinem Rechner und wird nicht mehr erkannt.

      Gibt es denn schon eine potentielle Lösung? So kann ich ja nicht mal eine neue Firmware flashen, selbst wenn ich das möchte, geschweige denn die Jumper als Controller verwenden.
    • Hab ich, bringt aber leider überhaupt nichts. Das Gerät verschwindet ja eben innerhalb weniger Sekunden (so 5-10 Sekunden) komplett wieder aus Windows, auch aus dem Geräte-Manager. Da hilft auch der installierte Treiber leider wenig. Im Bootloader-Modus habe ich dasselbe Problem. Da hier aber sofort der SD-Modus anspringt, konnte ich mit einem blitzschnellen Kommandozeilen-Copy auch die neueste Version der Firmware grad so noch kopieren, bevor die Jumper wieder weg war. Das Flashen der aktuellsten EdgeTX Nightly hat allerdings nichts verändert, das Problem besteht weiterhin.

      Anstecken, Gerät ist grundsätzlich da, fliegt aber nach 5-10 Sekunden (egal in welchem Modus) wieder aus Windows raus.

      Im Lademodus wird zwar dauerhaft ein unbekanntes Gerät von Windows gemeldet, aber da ist keine Hardware-ID und nichts dahinter, daher vermute ich, dass man in dem ohnehin gar nichts machen kann.
    • Ich benutze Windows selten für sowas. Ich habe das gerade mal ausprobiert, bei mir wird sie im Massenspeichermodus gar nicht erkannt (unbekanntes Gerät). Da scheint wohl ein Treiber zu fehlen. Windows Update findet auch keinen.
      HID Joystick geht aber problemlos:

      Das ist ein relativ jungfräuliches Windows 11. Da ist außer einer CAD-Suite und Office absolut nichts drauf. Auf der Kiste wurde bisher noch nicht mal ein Webbrowser benutzt.

      Der Massenspeichermodus scheint bei meiner T20 ein reines Windows Treiber Problem zu sein. Unter Linux klappt das wunderbar, out of the box:

      Source Code

      1. [32568.680527] usb 1-3.4.3: new full-speed USB device number 46 using xhci_hcd
      2. [32568.759041] usb 1-3.4.3: New USB device found, idVendor=0483, idProduct=5720, bcdDevice= 2.00
      3. [32568.759045] usb 1-3.4.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
      4. [32568.759049] usb 1-3.4.3: Product: Jumper T20 Mass Storage
      5. [32568.759050] usb 1-3.4.3: Manufacturer: EdgeTX
      6. [32568.759051] usb 1-3.4.3: SerialNumber: 00000000001B
      7. [32568.766892] usb-storage 1-3.4.3:1.0: USB Mass Storage device detected
      8. [32568.767076] scsi host5: usb-storage 1-3.4.3:1.0
      9. [32569.785230] scsi 5:0:0:0: Direct-Access JUMPER T-20 Radio 1.00 PQ: 0 ANSI: 2
      10. [32569.786110] sd 5:0:0:0: [sdg] 1007616 512-byte logical blocks: (516 MB/492 MiB)
      11. [32569.786314] sd 5:0:0:0: [sdg] Write Protect is off
      12. [32569.786315] sd 5:0:0:0: [sdg] Mode Sense: 00 00 00 00
      13. [32569.786505] sd 5:0:0:0: [sdg] Asking for cache data failed
      14. [32569.786505] sd 5:0:0:0: [sdg] Assuming drive cache: write through
      15. [32569.796839] sdg: sdg1
      16. [32569.797057] sd 5:0:0:0: [sdg] Attached SCSI removable disk
      Display All
    • Ich hab leider auch noch keine Lösung gefunden. Hab alles probiert, USB ports vom board, USB ports die direkt an die CPU angebunden sind, der einzige Unterschied ist wie schnell sie wieder rausfliegt. Ich hab selbst n alten USB Hub mit Powersupply rausgekramt, keine Veränderung. Einzig mein Laptop mag das Ding aber auch nur an der Docking Station, nicht direkt. Scheint mir fast so als ob das Ding Strom ausserhalb der USB specs zieht. Hab mit meiner Radiomaster keine Probleme die benutzt aber auch nen separaten Port zum Laden und zieht daher vielleicht weniger Strom.

      Bin am überlegen ob ich sie trotzdem behalte und mir einfach nen billigen ELRS Receiver bastele. Der Formfaktor ist halt schon sehr angenehm und mit neck Strap balancer Metalldingens hängt Sie sogar gerade am Band.
    • Für die Joystick-Funktion würde ich, wenn man sich keinen extra Empfänger bauen will, einfach einen Betaflight Quads als HID Schnittstelle benutzen. Ich finde es ein bisschen absurd, ausgerechnet das Gerät, dessen einziger Job Funkübertragung ist, über ein Kabel anzubinden. ;)
    • Ich habe heute Antwort von JumperRC erhalten und es liegt wohl am neuen Fast Charging Support, den aktuelle Revisionen der Funke erhalten haben. Ich habe ein Bild geschickt bekommen (und sogar ein kurzes Video) von zwei Kondensatoren, die man auslöten soll, dann soll die Kompatibilität via USB wohl wieder entsprechend besser sein.



      Das teste ich baldmöglichst mal aus, ich hab leider aktuell keinen Schraubenzieher, der tief genug in die schmalen Löcher der T20s kommt, um sie aufzuschrauben ;)